W:WordPress5にバージョンアップしたら、広告が消えてしまいマス

※コメントは↑のタイトルをクリックした先で入力可能デス。お待ちしてマス^^(クリックが反応しない場合は、コメント可能なページまで移動出来てマス。このまま下までスクロールしてみてくだサイ^^) イチ香(カ)への全体的なコメントは、上のメニューから掲示板をご利用くだサイ

こんばんは。

イチ香(カ)デス。

以前、バージョンアップしたWordpress最新5で、Javaのコードが動かない、
等の理由で、

頑張って旧バージョンに戻し、改善を見守って来ていマシタが、

とうとう、覚悟を決めてもう一回!

最新のバージョンにアップしマシタ。



一応、Classic Editor

というプラグインもいれて、インパクトに備えようと対処ルートを整え、

いざ。

意気込んだ結果・・・w

「・・・やっぱり動かない」

旧Editerのブログが、一度でも新バージョンで自動バックアップとられたら、

その時点で事象発生。

マジか・・・。



さてそれは何故だ。

よくよく考えて、

見比べて。

1台のPCに幾つ環境設定を変えてのブラウザ広げてたか、もう不明w

デスが、そこは知識は浅くとも、検証への食らいつき方はすっぽん並、というイチ香(カ)。

新しいeditorは、

新しい記事を作ろうとすると、改行する度に、下に新しいブロックが作成される仕組み。

そしてそのブロックが、細かく種類指定になっている事に着目。

という事は・・・と既存記事のブロック状態を確認すると、

もしかして、もしかしなくても、

旧エディターで作成した記事だと、全部が一つのブロックに入っちゃってる?

入っちゃってマスね~

なるほど! それでコードが、HTMLという認識がなされないのか!



という発見まで、至りマシタw

1時間近くかかりマシタよ^^;

きっと、Wordpressを使っている方にとっては大した事はない事例なのかも。

デスが、自力で辿り着けたというだけで、イチ香(カ)は満足^^

つまり、旧エディターで作成した文書を、一度でも編集モードで開き、自動保存がされちゃった瞬間には、

WordPress側では、新エディターで認識しちゃうので、

今まで問題なく表示されていたコード結果が、HTMLとは解釈されず、

思った通りに広告表示がされなくなったり、

借りもののカウンターが動かなくなったり、リンクが正しく表示されなくなったり、

という事象が出ちゃうんデスね~。



そこで、新エディターでコードを正しく認識させて動かすには、

ブロックの種類を選択しなければなりマセン。

左上にある̟⊕ボタンを押して、「整形」もしくは「layout」の中から、「カスタムHTML」というブロックの種類を指定しマス。

そうすると、そのブロックの中にHTMLソースを入れちゃえば、問題なくスクリプトが動くというわけデス。

ちなみに、Wordpress画面の右上にある縦の三点リーダーをクリックして、コードエディタを選択すると、

全体がコード入力、つまり、旧エディターのHTMLページのようになりマスね。

でもそれだと、ちょっと慣れない感じが続くので。

イチ香(カ)は思い切ってブロック使いを目指しマスw



そしてら、良いブロック種を発見^^

例えば、画像とか、繰り返し使うブロックは、

ブロックを選択すると、直ぐにプロパティが出てくると思いマスが、

その右端の三点リーダーをクリックすると、「再利用ブロックに追加」という項目があるのデス。

これを押すと、なんと。

左上の⊕からブロック種を選択した時に、「再利用可能」という項目から、

自分で登録したブロックが利用できるという事を発見。

繰り返し使う画像とか、コードとか、これで使えばらくちんデスね~^^



もしかしたら、もっと簡単な使い方はいろいろあるのかも知れませんが、

とりあえず、使いこなせるようになりそうなWordpress5デスw

これからもおデート、頑張りマス^^



それでは。

また次回の更新で。

イチ香(カ)デシタ。



コメントを残す

seventeen − 3 =