ジャバ

※初めてこのサイトでブログを読む方は、必ず先に「こちら」をお読みください。

※コメントは↑のタイトルをクリックした先で入力可能デス。お待ちしてマス^^(クリックが反応しない場合は、コメント可能なページまで移動出来てマス。このまま下までスクロールしてみてくだサイ^^)
イチ香(カ)への全体的なコメントは、上のメニューから掲示板をご利用くだサイ

 
 
こんばんは。
イチ香(カ)デス。

今日は12/7にリリースされたばかりのWordpressのバージョン5.0について。
いつもはリリースされても、一カ月くらいは様子見でバージョンアップしないのデスが、
昨日は、WiFiが復活した喜びの勢いで、思いッきりプラグインとかと一緒に更新しちゃいマシタ。
 
 

投稿のレイアウトが変わって、使いづらくなったな・・・と思うくらいは良かったのデスが、
Javaスクリプトが機能しないという大変な状況に^^;

 
 
出たよ。
出マシタよ。
これがまたしてもの洗礼。

広告とかのコードスタイルがJavaの方は今頃イチ香(カ)と同じように表示されなくなってパニックな筈デス。

気付いて直ぐに、検証開始。

バックアップデータからリストアしてもNG
プラグインを停止しても変わらず。
何がどうなってるんだと、ソースコードを確認したら、
スクリプトタイプがJavaのコードだけ、がっつりと文字化けというか、特殊に変換されて全く別物になっている事を確認。
 
 

マジか・・・><
改めてバックアップをとり、バージョンを戻す事にしマシタ!

 
 

手順は以下の通り。
1、まずはプラグインを全て停止して、
2、Wordpressのリリースページにアクセス。
3、4.9.8のZipをローカルにダウンロードして、
4、ffftpを使ってサーバーにアクセス。
5、wp-adminフォルダと、wp-includesフォルダを削除し、
6、3でダウンロードしたフォルダを解凍して、wp-contentを削除。
7、6のフォルダ内容を、全てffftpを使って、5で対応したサーバー上のファイルをアップロードで上書き。
8、完了したら、サイトを開いて、プラグインを有効化。
9、Javaを貼り直して、

 
 
おおおおお、動いた事を確認!
上記の対応が大体40分くらい。
そのうち、アップロードが25分くらいデス。

イチ香(カ)はサイトを二つ持っていマスが、
一つは5.0のまま。(このひとりごちデスね)
空想・夢想は4.9.8に戻して利用する事になりマシタ。

ひとりごちで取得しているコードはタイプが違っていたので影響無し。
Javaが困らないようなプラグインとかを、皆さん入れてたりするのかな・・・。
昨日の今日だからか、対応策がGoogle先生に聞いても得られませんデシタ。
今回は単純な事が原因だったので、手間はかかりマシタがどうにか自力で復旧。
もうしばらく待って、改善策か、もしくはリリースでの修復が確認出来たら、
空想・夢想は改めてバージョンアップしマス。
投稿の時にも、タグが連携出来てないところが悲しい・・・。
Wordpress、大好きデスが、やっぱりバージョンアップは危険デスw^^;
 
 
それでは。
また次回の更新で。
イチ香(カ)デシタ。